Commandes du menu

Le menu Actions
Le menu Annuler
Le menu Paquet
Le menu Solveur
Le menu Rechercher
Le menu Options
Le menu Vues
Le menu Aide

Le menu Actions

Figure 2.1. Commandes disponibles dans le menu Actions

CommandeDescription
Actions → Installer/enlever des paquets (g) Si un aperçu d'installation n'est pas visible, en affiche un. Sinon lance un processus d'installation comme décrit dans la section intitulée « Télécharger, installer et supprimer des paquets ».
Actions → Mettre à jour les listes de paquets (u) Met à jour la liste des paquets.
Actions → Marquer comme étant susceptible de mise à jour (U) Marque tous les paquets susceptibles de l'être, à l'exception de ceux qui sont gelés ou interdits de mise à jour, comme devant être mis à jour.
Actions → Oublier quels paquets sont nouveaux (f) Oublie quels paquets sont « nouveaux » (c'est-à-dire vide l'arborescence « Nouveaux paquets »).
Actions → Annuler les actions en attente Annule toutes les installations, les suppressions et les gels de paquets en attente. Cela revient à exécuter sur l'ensemble des paquets la commande pour les garder dans leur état actuel.
Actions → Nettoyer le cache des paquets Supprime toutes les archives de paquets qui ont été téléchargées par aptitude[a].
Actions → Enlever les fichiers périmés Supprime toutes les archives de paquets qui ont été téléchargées par aptitude[a] et qui ne sont plus disponibles dans les archives Debian. On peut supposer que ce sont des paquets obsolètes et qui peuvent être supprimés pour libérer de l'espace disque sans que cela ne nécessite de téléchargements inutiles par ailleurs.
Actions → Jouer au démineur Lance le démineur, comme cela est décrit dans la section intitulée « Jouer au démineur ».
Actions → Devenir administrateur Continue à travailler en tant qu'utilisateur root. Voir la section intitulée « Devenir administrateur (« root ») ».
Actions → Quitter (Q) Quit aptitude, saving any changes to package states.

[a] ou tout autre utilitaire apt.


Le menu Annuler

Figure 2.2. Commandes disponibles dans le menu Annuler

CommandeDescription
Annuler → Annuler (Contrôle+u) Cancel the effect of the last change to a package's state, up to the last time aptitude was started, the package list was updated, or an install run was performed.

Le menu Paquet

Figure 2.3. Commandes disponibles dans le menu Paquet

CommandeDescription
Paquet → Installer (+) Marque le paquet actuellement sélectionné pour installation.
Paquet → Supprimer (-) Marque le paquet actuellement sélectionné pour suppression.
Paquet → Purger (_) Marque le paquet actuellement sélectionné pour purge.
Paquet → Garder (:) Annule toute installation, mise à jour ou suppression prévue pour le paquet actuellement sélectionné et retire tout gel qui aurait été mis sur le paquet.
Paquet → Geler (=) Gèle le paquet actuellement sélectionné.
Paquet → Marquer automatiquement (M) Marque le paquet actuellement sélectionné comme étant un paquet « installé automatiquement ». Pour plus d'informations sur les paquets installés manuellement et automatiquement, consultez la section intitulée « Gérer les paquets automatiquement installés ».
Paquet → Marquer manuellement (m) Marque le paquet actuellement sélectionné comme étant un paquet « installé manuellement ». Pour plus d'informations sur les paquets installés manuellement et automatiquement, consultez la section intitulée « Gérer les paquets automatiquement installés ».
Paquet → Interdire la version (F) Si un paquet qui peut être mis à jour est sélectionné, cela interdit sa mise à jour vers la version actuellement disponible uniquement. Si une version du paquet est sélectionnée, cela interdit au paquet d'être mis à jour vers cette version.
Paquet → Informations (entrée) Affiche un écran contenant des informations sur le paquet actuellement sélectionné, comme les paquets dont il dépend, les paquets qui en dépendent, et ses versions disponibles.
Package → Cycle Information (i) When browsing the package list, cycles through the information that can be displayed in the information area (the lower half of the display). The information area can display the long description of the selected package (its default behavior), a summary of the dependencies related to the package, or an analysis of which other packages require or suggest the selected package.
Paquet → Liste des modifications (C) Affiche la liste des modifications du paquet Debian actuellement sélectionné. Pour voir les modifications d'une version particulière, sélectionnez cette version avant d'exécuter cette commande.

Le menu Solveur

Figure 2.4. Commandes disponibles dans le menu Solveur

CommandeDescription
Solutions → Examiner la solution (e) Affiche une description détaillée de la suggestion actuelle.
Solutions → Appliquer la solution (!) Exécute les actions actuellement suggérées.
Solutions → Solution suivante (.) Sélectionne la suggestion suivante.
Solutions → Solution précédente (,) Sélectionne la suggestion précédente.
Solutions → Première solution (<) Sélectionne la première suggestion.
Solutions → Dernière solution (>) Sélectionne la suggestion la plus récente (voir la section intitulée « Résoudre les problèmes de dépendance »).
Solutions → Marquer comme rejeté (r) Lors de l'examen d'une solution, rejette l'action actuellement sélectionnée et passe à l'action suivante (voir la section intitulée « Résoudre les problèmes de dépendance »). Si l'action était dans l'état approuvé, son approbation est annulée.
Solutions → Marquer comme retenu (a) Lors de l'examen d'une solution, approuve l'action actuellement sélectionnée et passe à l'action suivante (voir la section intitulée « Résoudre les problèmes de dépendance »). Si l'action était dans l'état rejeté, son rejet est annulé.
Solveur → Afficher la cible (entrée) Lors de l'examen d'une solution, affiche des informations détaillées sur le paquet touché par l'action actuellement sélectionnée (voir la section intitulée « Résoudre les problèmes de dépendance »).
Resolver → Reject Breaking Holds Reject (as if with Solutions → Marquer comme rejeté (r)) all actions that would break a hold on a package or install a forbidden version. These actions are rejected by default unless Aptitude::ProblemResolver::Allow-Break-Holds is set to true, but this menu item allows you to reject them manually at any time.

Le menu Rechercher

Figure 2.5. Commandes disponibles dans le menu Rechercher

CommandeDescription
Rechercher → Rechercher (/) Recherche le paquet suivant dans la liste des paquets qui correspond au motif de recherche (voir la section intitulée « Motifs de recherche »).
Search → Rechercher en arrière (\) Recherche le paquet précédent dans la liste des paquets qui correspond au motif de recherche (voir la section intitulée « Motifs de recherche »).
Rechercher → Rechercher à nouveau (n) Répète la dernière recherche.
Rechercher → Rechercher en arrière (N) Répeter la dernière commande, mais dans le sens inverse. Si la dernière commande Rechercher était Rechercher vers le haut, alors cela exécutera un Rechercher vers le bas, et vice versa.
Rechercher → Affichage restreint (l) Filtre la liste de paquets en omettant tous les paquets qui ne correspondent pas au motif de recherche (voir la section intitulée « Motifs de recherche »).
Rechercher → Affichage complet Retire le filtrage de la liste de paquets (tous les paquets sont affichés).
Rechercher → Rechercher les cassés (b) Find the next broken package. This is equivalent to searching for ?broken.

Le menu Options

Figure 2.6. Commandes disponibles dans le menu Options

CommandeDescription
Options → Preferences Open a new top-level view in which you can modify aptitude's settings. Configuration options are displayed in a tree similar to the tree of packages; to enable or disable an option, select it and press Space or Enter. Configuration options are saved to ~/.aptitude/config immediately upon being selected.
Options → Revenir aux options par défaut Revient aux options de configuration par défaut.

Le menu Vues

[Note]Note

Pour un aperçu du fonctionnement des vues, voir la section intitulée « Travailler avec plusieurs vues ».

Figure 2.7. Commandes disponibles dans le menu Vues

CommandeDescription
Vues → Suivant (F6) Va à la vue active suivante.
Vues → Précédent (F7) Va à la précédente vue active.
Vues → Fermer (q) Ferme la vue actuelle.
Vues → Nouvelle vue des paquets Crée une nouvelle vue de la liste des paquets.
Vues → Voir les recommandations Crée une vue qui affiche les paquets qui ne sont pas installés et qu'un paquet installé sur votre système recommande.
Vues → Nouvelle liste des paquets Crée une nouvelle vue de la liste des paquets dans laquelle les paquets ne sont pas triés.
Vues → Consultation par « Debtags » Crée une nouvelle vue de la liste des paquets dans laquelle les paquets sont rangés en fonction de leur entrée debtags.
Vues → Consultation par catégories Affiche la liste des paquets, organisée par catégorie.
Entrées supplémentaires D'autres entrées du menu apparaissent. Il s'agit des vues actuellement actives. Pour atteindre directement une vue, sélectionnez-la dans ce menu.

Le menu Aide

Figure 2.8. Commandes disponibles dans le menu Aide

CommandeDescription
Aide → À propos Affiche des informations de copyright.
Aide → Aide (?) Affiche l'aide en ligne.
Aide → Manuel Utilisateur Affiche le manuel de l'utilisateur (ce document).
Aide → FAQ Affiche la FAQ d'aptitude.
Aide → Liste des modifications Affiche la liste des principales modifications apportées à aptitude.
Aide → Licence Affiche les termes de la licence sous laquelle vous pouvez copier, modifier et distribuer aptitude.